Upgrading Add-in Project in Ver. 9 Format to Ver. 10 Format


To use add-in projects created in RootPro CAD Ver. 9 in RootPro CAD Ver. 10, it is necessary to upgrade the projects with the following procedures.

Add-ins for RootPro CAD Ver10 can be created with "Visual Studio 2019/2017/2015".
If you are using "Visual Studio 2013", please install "Visual Studio 2019".
Downloading "Visual Studio 2019"

  1. Start up RootPro CAD Professional, and click [Add-ins] - [Launch Visual Studio] menus.
    Visual Studio will start up.
  2. Click [File] - [Open project] menus in Visual Studio to select a solution file (.sln) for an add-in project.
  3. Click [Project] - [(ProjectName) property] menu to display the setting screen for the project.
  4. Modify [Target framework:] on [Apps:] to [.NET Framework 4.6.2].
    Supplemental
    If only versions before [.NET Framework 4.6.1] are displayed in the box in "Visual Studio 2015", download and install ".NET Framework 4.6.2 Developer Pack."
    Downloading ".NET Framework 4.6.2 Developer Pack"
  5. Select [Start External Program] on [Debug], and click [...] on the right.
    [Select File] dialog box will be displayed.
  6. Select RootProCAD.exe in a folder RootPro CAD is installed, and click [Open].
    Normally, the path is "C:\Program Files\RootPro CAD 10 Professional\RootProCAD.exe".
  7. Click [File] - [Save All] menus.

Build of add-in projects

  1. Select [Build] - [Build Solution] menus.
    Build will be executed, and an add-in file (.dll) will be created.
  2. Select [Debug] - [Start debugging] menus.
    Professional will start up, so check that the add-in operates correctly.
Supplemental
Add-ins are only used in RootPro CAD Professional. RootPro CAD Free cannot use these functions.

Related topics