Saving in AutoCAD File Format (DWG/DXF)


Saving in AutoCAD file format

  1. On [File] menu, click [Export] - [Export to DXF File] / [Export to DWG File].
    [Export] dialog box will be displayed.
  2. Select a saving location.
  3. Enter a file name in [File Name] box.
  4. Click [Save] button.
    The drawing created in RootPro CAD will be saved as an AutoCAD drawing file.

Setting to save in AutoCAD file format

  1. On [File] menu, click [Import/Export Options] - [DXF/DWG File Settings].
    [DXF/DWG File Settings] dialog box will be displayed.

    Select [Export] tab, make necessary settings, and click [OK] button.

Restrictions on saving in AutoCAD file format

When saving a drawing file created in RootPro CAD as an AutoCAD drawing file (DXF/DWG), the following restrictions will apply.

■ Saving format

Any of [R13/LT95], [R14/LT98/97], [2000/LT2000], [2004/LT2004], [2007/LT2007], [2010/LT2010], [2013/LT2013], and [2018/LT2018].

■ Shape data after conversion

Shapes in RootPro CAD drawing files saved as AutoCAD files are converted in the following shapes.

RootPro CAD shape data AutoCAD shape after conversion
Line LINE
Point POINT of "·" type
Circle CIRCLE
Arc ARC
Ellipse ELLIPSE
Elliptical arc ELLIPSE
Text When a text has 1 line with the number of characters at 256 (single byte) or less, it will be converted as TEXT.
When a text has more than 256 (single byte) characters, or multiple lines, it will be converted as MTEXT (multiple texts).
* Horizontally aligned fonts are converted to TrueType fonts or big fonts (specified by an option).
* When converting vertically aligned fonts to MTEXT, the system will modify the base of locate place, and rotate fonts by 90 degrees.
* When converting vertically-aligned fonts to TEXT, they will be converted to big fonts.
* Vertically aligned fonts have a character angularity of 0 degrees.
* Single-byte characters of TEXT are rotated by 90 degrees.
* A character pitch is 0.
* When converting vertically or horizontally reversed text to MTEXT, the reverse setting will be nullified.
* The text height (with option settings), locate base point, etc. are automatically adjusted to fit to DXF/DWG specifications as close as possible.
Lead TEXT and POLYLINE, SOLID, CIRCLE
Balloon TEXT and POLYLINE, SOLID, CIRCLE
Dimension DIMENSION
* An option to explode to basic shapes is available. Tolerances are always exploded to basic shapes.
Hatch Solid hatches are converted to solid type HATCHs.
Pattern hatches are converted any of SOLID, LINE, NET, DOTS, DASH, ZIGZAG and BRICK in AutoCAD.
User-defined hatches (line hatch patterns) are converted to user-defined or defined types with the same name, or custom type hatches.
User-defined hatches (shape hatch patterns) are converted after being exploded to basic shapes.
* Patterns and solid shapes are converted when a saving format is [R14/LT98/97] or later.
* Transparency for solid hatches is converted when a saving format is [2010/LT2010] or later (Max. 90%). Note that, however, only AutoCAD 2011 or later versions can handle transparency.
* When converting a user-defined hatch, opening the converted file in AutoCAD and editing it, the line pitch may change, or a value may not be modified. This is caused by the inconsistency in the hatching pattern in AutoCAD and that written in RootPro CAD. RootPro CAD does not modify or create a pattern file. To edit these hatches in AutoCAD, re-draw them.
Drawing Group Converted to a group.
Drawing component INSERT (block insert) and BLOCK (block).
* Any drawing component in RootPro CAD located with the layer [None], INSERT located on 0 layer (block insert).
* Attributes are also converted.
* An option to explode drawing components to basic shapes is available.
Image Save an image file in the same place as for the saved AutoCAD file (DXF/DWG).
File name is the same as AutoCAD file (DXF/DWG).
* For multiple image files, numbers are added to the last of the file name.
* Converted when a save format is [R14/LT98/97] or later.
* Formats for image files can be specified in either TIFF (monochrome), BMP, JPEG, or PNG (using an option).
* RootPro CAD creates a block of part drawings, but not images when converting paper.
In such a case, images are converted to first data for individual part drawings.
OLE object OLE object

■ After converting color No. and name

Color Nos. and names in RootPro CAD drawing files saved as AutoCAD files are converted to the following Nos. and names.

Color No. in RootPro CAD: Color name Color No. in AutoCAD after conversion: Color name
Layer color BYLAYER
1: Black 250 or optionally 8: White
2: Red 1: Red
3: Green 3: Green
4: Blue 5: Blue
5: Yellow 2: Yellow
6: Purple 6: Magenta
7: Aqua 4: Cyan
8: White 7: White
9: Peony pink 222
10: Brown 33
11: Orange 30
12: Light green 95
13: Light blue 150
14: Blue purple 181
15: Light gray 9
16: Charcoal 8
17 and after Colors having close color values

■ Converting line type

Line type Nos. and names in RootPro CAD drawing files saved as AutoCAD files are converted to the following line type names.

Line type No. in RootPro CAD: Line type name Line type name in AutoCAD after conversion
Layer Line Type BYLAYER
2: Dashed ACAD_ISO02W100
3: Dashed spaced ACAD_ISO03W100
4: Long dashed dotted ACAD_ISO04W100
5: Long dashed double-dotted ACAD_ISO05W100
6: Long dashed triplicate-dotted ACAD_ISO06W100
7: Dotted ACAD_ISO07W100
8: Chain ACAD_ISO08W100
9: Chain double-dashed ACAD_ISO09W100
10: Dashed dotted ACAD_ISO10W100
11: Double-dashed dotted ACAD_ISO11W100
12: Dashed double-dotted ACAD_ISO12W100
13: Double-dashed double-dotted ACAD_ISO13W100
14: Dashed triplicate-dotted ACAD_ISO14W100
15: Double dashed triplicate-dotted ACAD_ISO15W100
Other line types Same name (Line parts whose pitch length 0.1d (d= 0.5 for settings where pitches are proportional to line widths) at 0.05 or less are converted 0 as dots.)
Tip:
When selecting [Pitch Proportional With Line Width] in the line type table in RootPro CAD, pitch will be 0.5, and when selecting [Pitch Not Proportional With Line Width], the d value will be converted to a global line type scale (LTSCALE).
[Use Paper Space Unit for Scale Settings] option for DXF/DWG (PSLTSCALE) is converted to OFF (0).

■ Line type conversion

When saving files in data formats for AutoCAD 2000/AutoCAD LT2000 or later, line widths will be set for individual shape data. Data formats for before AutoCAD 2000/AutoCAD LT2000 cannot set the line width for shape data.

Others
When converting a drawing with multiple part drawings without specifying a necessary part drawing, all part drawings will be converted on modeling space in DXF/DWG.
When [Specify Size] is selected for paper size, a standard size close to the specified value will be selected.
If there is a part drawing layout with different X/Y scales, part drawing layout will be located as a block in AutoCAD.

Related topics