Saving in SXF File Format (SFC/P21)


Saving in SXF file format

Drawing files created by RootPro CAD can be saved in level 2 SXF file format.

  1. On [File] menu, click [Export] - [Export to SFC File] / [Export to P21 File].
    [Export] dialog box will be displayed.
  2. Select saving location.
  3. Enter a file name in [File Name] box.
  4. Click [Save] button.
    The drawing created in RootPro CAD will be saved as an SXF file.

Setting to save in SXF file format

  1. On [File] menu, click [Import/Export Options] - [SXF File Settings].
    [SXF File Settings] dialog box will be displayed.

    Select [Export] tab, make necessary settings, and click [OK] button.

Restrictions on saving in SXF file format

RootPro CAD can save a file as an SXF (SFC/P21) file of level 2. When saving a drawing file created in RootPro CAD in SXF file (SFC/P21) format, shape data will be converted to those suited to SXF (SFC/P21).

RootPro CAD shape data SXF shape after conversion
Paper If multiple sheets of paper are used, active sheet of paper and its part drawing layout will be converted.
When multiple part drawing layouts are located for the same part drawing on paper, new part drawings are created for each layout, and then converted.
When converting paper with print scale at other than 1.5 (paper other than in millimeters), shapes on paper are exploded, and enlarged/shrunken according to print scale. Print scale also applies to part drawing layout scales.
Layer groups and layers A layer name is made by combining its layer group name and layer name.
If there are more than 256 layers, the settings for the 256th layer will be used for all subsequent layers. ("View" for [View/Invisible])
Basic line type Defined line type (No restrictions)
User-defined line type All of 32nd and subsequent line types are solid lines.
Defined color Defined color (No restrictions)
User-defined color No restrictions
Line width No restrictions
Point Point marker
* Points other than drawing components are converted to the scaled size.
* If the point type is solid, the point type will be converted to the transparent one with the same shape.
Line Line (No restrictions)
Polyline Polygonal line (No restrictions) * If a clothoid parameter is added to the attribute, using [Export Options] option for the SXF file,
set the saving format to [SXF Specification V3] and turn on [Convert Clothoid] to convert to clothoid curves according to attribute details.
For attributes, see "Clothoid attribute for polygonal lines" in "Saving in SXF Specification V3 Format."
Circle Circle (No restrictions)
Arc Arc (No restrictions)
Ellipse Ellipse (No restrictions)
Elliptical arc Elliptical arc (No restrictions)
Text Text
* Transparent and vertical/horizontal reverse are invalid (since they are not supported by SXF specifications).
* Strings in multiple lines are exploded to single lines, and then converted (since this is not supported by SXF specifications).
B-Spline Spline curve
Infinite line Converted to lines (since this is not supported by SXF specifications).
Ray Converted to lines (since this is not supported by SXF specifications).
Dimension (length, angle, radius, diameter, arc). Dimension
* To match the visual size on paper, the arrow size is converted to a size calculated by multiplying by the locate scale of the part drawing layout.
* The arc dimension is converted to the arc length dimension, but when auxiliary lines are parallel (since this is not supported by SXF specifications), and when a saving format is set to [SXF Specification V2] in [Export Options] for the SXF file, they are exploded to lines, arcs, texts, and hatches.
Lead When the arrow type is [None], black circles are used with the layout magnification at 0.01.
If texts are in multiple lines, they are exploded to leads and texts.

* To match the visual size on paper, the arrow size is converted to a size calculated by multiplying by the locate scale of the part drawing layout.

Balloon When the arrow type is [None], black circles are used with the layout magnification at 0.01.
When the arrow type is [Square], it is exploded to a lead and polyline.
Balloons without lead are exploded to circles and texts, or polylines and texts.
If strings are in multiple lines, they are exploded to leads and texts.

* To match the visual size on paper, the arrow size is converted to a size calculated by multiplying by the locate scale of the part drawing layout.

Hatch Blotted type hatches are converted to Hatch (solid).
Pattern hatches are converted to (defined) hatches.
Line types for user-defined hatches with 4 lines or less (since SXF specifications only supports 4 lines or less) are converted to (user-defined) hatches.
Shape types for user-defined hatches with "sxf_hatch_style_7_symbol" or "sxf_hatch_style_8_symbol" on the top of the name are converted to hatches in Umafumi (brick-like pattern) and 45 degree Kasane Ajiro (diagonal brick-like pattern), respectively. Others are exploded to basic shapes, and then converted.
Part Drawing Part drawing
* If a converted drawing component and drawing group have a part drawing under the same name, add an integer number to the part drawing name to change it.
* If there is a character string "$$SXF_FG" in the explanation of the part drawing, it converts it as a part drawing of the geodetic coordinate system.
Drawing component Drawing component

* A shape containing a dimension, lead, balloon or point is exploded to match the size of arrow/point to that on paper.
* Drawing components laid out with a negative scale are exploded. (Since SXF specifications do not support it.)
* A drawing component containing a shape using a layer color, layer line type, or layer line width is exploded. (Since SXF specifications do not support them.)

Composite shape (drawing group) Add an integer to the "DrawGroup" in the drawing group name.
Image Raster data
If there are multiple images on the drawing when exported to a file in [SXF Specification V2], the first image on RootPro CAD database will be saved as an image file. The image file format will be TIFF G4 according to SXF specifications, and the color will be in monochrome. Exporting a file in [SXF Specification V3] enables to convert multiple images. The color images are saved as JPEG image files.
* Files are saved in the same location as SXF files.
* Image files are saved in the same location as SXF files. If a file name is registered to an attribute, the name and format (with the extension of ".tif" or ".jpg") are used with priority. If it is not registered to an attribute, the file will have the same name as SXF files. Multiple files are numbered with "(n)" (n: integer) after the file name.
* The extension is ".tif" or ".jpg".
* If there is an image on a part drawing in RootPro CAD, it will be automatically converted on paper according to SXF specifications. Note that, however, display orders for paper and part drawings are freely changed in RootPro CAD, which may cause images overlaid on shapes on other part drawings, depending on the displaying order of paper and part drawing. When there is an image on a part drawing, move the image to paper and check the display status before exporting.
Object Not converted (since this is not supported by SXF specifications)

Saving in SXF Specification V3 Format
Background color The background color is set to Area_control (defined hatch) when exporting.
Attribute Types of SXF Attribute Addition Mechanisms and Details Attribute Name in RootPro CAD
Among attributes registered to shapes in RootPro CAD, the attribute values in the following attribute names are converted according to the attribute addition mechanism for SXF files.
Attribute Name in RootPro CAD Types of SXF Attribute Addition Mechanisms and Details
SXF_ATRF_NUMBER "Shape ID No." of the attribute addition mechanism for attribute file (ATRF)
SXF_ATRF_SAF_FILENAME "Attribute File Name" of the attribute addition mechanism for attribute file (ATRF)
SXF_ATRU_NUMBER "Shape ID No." of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRU_FEATURE_NAME "Shape Name" of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRU_ATTRIBUTE_NAME "Attribute Name" of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRU_ATTRIBUTE_VALUE "Attribute Value" of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRU_ATTRIBUTE_TYPE "Attribute Type" of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRU_ATTRIBUTE_UNIT "Unit" of the attribute addition mechanism for single attribute (ATRU)
SXF_ATRS_NUMBER "Shape ID No." of the attribute addition mechanism for text features (ATRS)
SXF_ATRS_ATTRIBUTE_NAME "Attribute Name" of the attribute addition mechanism for text features (ATRS)
SXF_ATRS_ATTRIBUTE_TYPE "Attribute Type" of the attribute addition mechanism for text features (ATRS)
SXF_ATRS_ATTRIBUTE_UNIT "Unit" of the attribute addition mechanism for text features (ATRS)
* The same "Shape ID No." in multiple shape attributes will cause an error when exported.
If a part drawing is located as multiple layouts in RootPro CAD, shapes with attributes for the drawing will be copied in the number of layouts when converted to an SXF file, causing the Shape ID No. to be duplicated. When exporting as an SXF file, be sure to allocate one part drawing on one layout.
File Properties [User Settings] of [File Properties] in RootPro CAD Parameter for [SXF Drawing Attribute]
Name of [User Settings] Type of [User Settings] Description
SXF_PROJECTNAME String Project name
SXF_CONSTRUCTIONNAME String Construction name
SXF_CONTRACTTYPE String Contract type
SXF_DRAWINGTITLE String Title
SXF_DRAWINGNUMBER String Drawing Number
SXF_DRAWINGTOTAL String Total (an optional value that can be added after the drawing number)
SXF_DRAWINGTYPE String Drawing Type
SXF_DRAWINGSCALE String Scale
SXF_DRAWINGDATE Date Year/month/day of drawing date
SXF_CONTRACTOR String Contractor
SXF_OWNER String Owner
* If there is any property having the above name in [User Settings] of [File Properties] in RootPro CAD, [SXF Drawing Attribute] will be converted (all attributes other than SXF_DRAWINGTOTAL must be set.) The contents in [SXF Drawing Attribute] may be checked and modified as [SXF Drawing Attribute] dialog box is displayed when exporting, if [Check Drawing Attribute] is ticked on [SXF File Settings - Export] dialog box.
Clothoid attribute for polylines Attribute Name for Polylines in RootPro CAD Parameter for Clothoid Features in SXF
SXF_CLOTHOID_BASE_X Locate base point X coordinate
SXF_CLOTHOID_BASE_Y Locate base point Y coordinate
SXF_CLOTHOID_PARAMETER Parameter
SXF_CLOTHOID_DIRECTION Direction flag (0: Counterclockwise, 1: Clockwise)
SXF_CLOTHOID_ANGLE Rotation angle (degree)
SXF_CLOTHOID_START_LENGTH Start curve length
SXF_CLOTHOID_END_LENGTH End curve length
* To convert polylines to clothoids, all the attribute above must be set. For details of parameters, refer to "SXF Ver.3.1 Specifications/Manual."
* RootPro CAD does not have a function to automatically generate clothoid parameters.
* Even with the above attributes, if the start and end points of a polyline is not on the clothoid curve created based on parameters, it will be converted to a polyline.

 

Supplemental
RootPro CAD has standard foundation software (sfc shared library)
developed by the Japan Construction Information Center on behalf of the Ministry of Land, Infrastructure, Transport and Tourism to import and export SFC/P21 files.

Related topics